Last Updated: 12/July/2018
Affected products
- SVF for PDF Ver. 8.0 to 9.2
- SVF for Java Print Ver. 8.0 to 9.2
- SVF for PDF Client Edition Ver. 9.2
- Report Director Enterprise Ver. 8.0 to 9.2
- RDE Scalable Edition Ver. 8.1.1 to 8.2.6
- RDE Limited Ver. 9.2
Summary
In cases wherein the affected products are connected to:
- SVF Connect for ASP/COM API
- SVF Connect for .NET Framework API
- SVF Connect for Java API
the performance may degrade during off-peak hours, and severely deteriorate during peak hours. For example, a 2 to 3 paged PDF document, which usually just takes a few seconds to print, may take more than few minutes to complete.
(Note: There's a possibility that performance may degrade even if not connected to SVF Connect products.)
Cause
This issue occurs when housekeeping for session log file is not periodically performed on the machine, and the amount of log files becomes overwhelmingly large (over 1M files).
Resolution
Perform the following to resolve the issue:
1. Determine the output location of the log file.
a) If the output directory was specified:
SVF Execution Unit Ver. 8.0 to 9.0: Go to the location specified by the -L option
SVF Execution Unit Ver. 9.1 to 9.2: Go to the location specified by the -F option
Note: For more details on the above options, please read the manuals SVF Connect for Java API ver 9.2 or SVF Connect for .NET Framework API ver. 9.2.
b) If the output directory was not specified:
For Windows
Open the service manager console and look for either [SvfJavaConnectServer] or [SvfrServer]. Right click on either of the two service names and click [Properties] then [Log On], to determine which user owns the service. If Local System Account is selected, then go to [%SystemRoot%\Temp]
For Linux
Go to the temp folder, usually [/tmp], of the user that started the process. The default user is [svf].
2. Delete or move the log files.
If you see a huge number of session logs, you may want to either move them to a different folder or delete them altogether. We strongly recommend constant housekeeping to avoid future performance degrade.
Additional Information
Log filenames may vary depending on the SVF Execution Unit version being used.
- SVF Execution Unit Ver. 8.0 to 8.1
SvfrServer-yyyyMMddhhmmss<Timestamp>-aaa.aaa.aaa.aaa<Client's IP>-pppp<Client's Port Num>.log - SVF Execution Unit Ver. 8.2 to 9.2
SvfrServer.Port.pppp<ServerPort>-yyyyMMddhhmmss<Timestamp>-aaa.aaa.aaa.aaa<Client IP>-pppp<ClientPort>.log
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